软件指南针:专注于软件传播与分享

解决Ubuntu安装OpenVPN报错的问题

来源:原创 7793次浏览 0条评论
☞ 本文主要介绍软件Ubuntu的相关内容:解决Ubuntu安装OpenVPN报错的问题

   其下列版本/分支可以参考本文:

  • 全部版本/分支

与Windows系统相比,Linux下安装OpenVPN的过程就显得有点曲折。

如果你使用的是Ubuntu系统,你可以直接使用命令sudo apt-get install -y openvpn来安装OpenVPN。

不过使用该命令安装的OpenVPN一般都不是最新版本,如果你想手动安装最新版本的OpenVPN,你可以点击这里下载Linux版的OpenVPN

安装OpenVPN之前,你必须先确保Ubuntu上已经安装了C编译器(例如gcc)、OpenSSL、LZO(一种无损压缩算法)、PAM(一种可插入式的身份验证模块)。

  1. 如果你没有安装OpenSSL,则会提示:
    configure: error: ssl is required but missing
    解决方法是执行命令:sudo apt-get install libssl-dev
  2. 如果你没有安装lzo,则会提示:
    configure: error: lzo enabled but missing
    解决方法是执行命令:sudo apt-get install liblzo2-dev
  3. 如果你没有安装PAM,则会提示:
    configure: error: libpam required but missing
    解决方法是执行命令:sudo apt-get install libpam0g-dev
更多信息请参考Linux下OpenVPN的详细安装配置教程

作者:软件指南针(http://www.softown.cn),转载请保留出处!

用户评论

使用指南 故障排除 0 返回顶部